Asteroid: a Mac-friendly Bitcoin/Litecoin frontend to cgminer

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with Twitter

In this Discussion

Like Asteroid?
Donate some of your hashing time using the in-app slider: Your contributions will help Asteroid stay active and keep it the best Mac miner out there!
Subscribe to push notifications for Asteroid releasesYou can unsubscribe any time from Safari's Preferences.
Version 0.9.7 is now out -- release notes and download
Live coin balances, new mining engine, bugfixes and more
Share Above Target Errors
  • Hi,

    I'm new to mining LTC and I'm testing out Asteroid on my iMac. I've been running the UI app just fine, but it looked like most of my shares weren't being accepted. I then switched over to the command line to see if I could figure out what was going on.

    It looks like most of my shares are "Share Above Target" errors. Any idea how to fix this?

    My cgminer options:
    ./cgminer --scrypt --intensity=8 -o stratum+tcp://us3.wemineltc.com:3333 -u dyn4mik3.1 -p x --thread-concurrency 3200 -g 1 -w 256

    Here's the output from verbose option of cgminer:

    cgminer version 3.7.2 - Started: [2013-12-02 09:02:25]
    --------------------------------------------------------------------------------
    (5s):31.85K (avg):30.15Kh/s | A:162 R:0 HW:0 WU:28.7/m
    ST: 2 SS: 0 NB: 5 LW: 52 GF: 0 RF: 0
    Connected to us3.wemineltc.com diff 45 with stratum as user dyn4mik3.1
    Block: a0c1511e... Diff:1.73K Started: [09:09:40] Best share: 157
    --------------------------------------------------------------------------------
    [P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
    GPU 0: | 31.84K/30.37Kh/s | A:162 R:0 HW:0 WU:29.0/m I:10
    --------------------------------------------------------------------------------

    [2013-12-02 09:09:30] Share above target
    [2013-12-02 09:09:32] (5s):32.06K (avg):30.09Kh/s | A:162 R:0 HW:0 WU:28.5/m
    [2013-12-02 09:09:32] Share above target
    [2013-12-02 09:09:33] Share above target
    [2013-12-02 09:09:37] (5s):32.09K (avg):30.12Kh/s | A:162 R:0 HW:0 WU:28.4/m
    [2013-12-02 09:09:39] Share above target
    [2013-12-02 09:09:40] New block: a0c1511e9a863f105a4f581a57db5076cc587967a20d82993f26c825be74a745... diff 1.73K
    [2013-12-02 09:09:40] Stratum from pool 0 detected new block
    [2013-12-02 09:09:40] Work update message received
    [2013-12-02 09:09:42] (5s):31.91K (avg):30.13Kh/s | A:162 R:0 HW:0 WU:28.3/m
    [2013-12-02 09:09:43] Share above target
    [2013-12-02 09:09:43] Share above target
    [2013-12-02 09:09:44] Share above target
    [2013-12-02 09:09:45] Share above target
    [2013-12-02 09:09:45] Share above target
    [2013-12-02 09:09:46] Share above target
    [2013-12-02 09:09:47] (5s):31.85K (avg):30.15Kh/s | A:162 R:0 HW:0 WU:28.7/m
    [2013-12-02 09:09:49] Share above target
    [2013-12-02 09:09:51] Share above target
  • KarinKarin
    Posts: 597
    Hrm, I haven't seen that error before. Looking around the internet, it appears that sometimes that error may be temporary, going away after 10-15 minutes as perhaps the pool adjusts itself. Do you see this problem consistently? Have you tried a different pool to see if you get the same? Let us know :)
  • Tried switching to a different pool (from wemineltc to give-me-coins). Still seeing the same problem consistently even when I let it sit for a while:

    cgminer version 3.7.2 - Started: [2013-12-02 14:53:18]
    --------------------------------------------------------------------------------
    (5s):7.982K (avg):7.736Kh/s | A:16 R:0 HW:0 WU:11.2/m
    ST: 2 SS: 0 NB: 1 LW: 11 GF: 0 RF: 0
    Connected to ltc.give-me-coins.com diff 64 with stratum as user dyn4mik3.1
    Block: 7c7bfe0b... Diff:1.73K Started: [14:53:18] Best share: 31
    --------------------------------------------------------------------------------
    [P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
    GPU 0: | 7.908K/7.862Kh/s | A:16 R:0 HW:0 WU:11.2/m I: 8
    --------------------------------------------------------------------------------

    [2013-12-02 14:54:45] (5s):7.844K (avg):7.652Kh/s | A:16 R:0 HW:0 WU:9.0/m
    [2013-12-02 14:54:47] New best share: 31
    [2013-12-02 14:54:47] Share above target
    [2013-12-02 14:54:47] Share above target
    [2013-12-02 14:54:48] Share above target
    [2013-12-02 14:54:50] (5s):7.281K (avg):7.583Kh/s | A:16 R:0 HW:0 WU:10.4/m
    [2013-12-02 14:54:53] Share above target
    [2013-12-02 14:54:55] (5s):8.194K (avg):7.690Kh/s | A:16 R:0 HW:0 WU:10.5/m
    [2013-12-02 14:54:58] Share above target
    [2013-12-02 14:54:58] Pool 0 difficulty changed to 64
    [2013-12-02 14:54:59] Work update message received
    [2013-12-02 14:54:59] Share above target
    [2013-12-02 14:55:00] (5s):8.107K (avg):7.704Kh/s | A:16 R:0 HW:0 WU:11.1/m
    [2013-12-02 14:55:01] Share above target
    [2013-12-02 14:55:02] Share above target
    [2013-12-02 14:55:05] (5s):8.035K (avg):7.714Kh/s | A:16 R:0 HW:0 WU:11.7/m
    [2013-12-02 14:55:10] (5s):8.029K (avg):7.728Kh/s | A:16 R:0 HW:0 WU:11.2/m
    [2013-12-02 14:55:13] Share above target
  • ferroferro
    Posts: 1
    Were you able to put it working? I have the same problem...